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RealSpace™ 360 (“RS360”) Cinema Features include:
●
●
●
●
●
●
●
●

Standalone mode: use to import mono or ambisonic tracks directly (without DAW) for
authoring spatial audio
3D ‘scene editor’ to view spatial positions and paths
Keyframe editing to control XYZ position and volume automation of any sound source
over a timeline
Ambisonic import: Up to 7th order ambisonics track in sync with object based tracks with
ability to rotate the sound field to match the video
Ambisonic export (up to 7th order)
○ Inject ambiX ambisonic format (ACN/SN3D) to video for YouTube upload
Passthrough mode: allows selected tracks to bypass headtracking
Live 360 video with HMD head-tracking (HMD mode for Windows only)
Digital Audio Workstation (DAW) Mode: stream discrete tracks from your favorite DAW
○ MIDI Time Code support (MTC) for slave mode sync with Pro Tools (standard or
HD), Logic Pro, Nuendo, Reaper, and more

Purpose
This editor creates a simple workflow for adding 3D audio into a 360 degree video. Simply place
audio source tracks at the location in space and time you want it to appear to the viewer, and
the audio will be appear there (and heard in the correct location in 3d space upon playback.) For
a moving source, you can specify the audio at different locations and times on the video over
time, and the audio will smoothly interpolate along the defined path. Once the mix is finalized,
the audio can be exported in various formats, and automatically injected into the video file.
The editor is designed to work as a standalone application for authoring spatial audio paths
alongside a 360 video using the editor’s 360 video player. In addition, any DAW can be used
alongside the editor: audio can be routed to the editor with the two applications synchronized
using MIDI Time Code.
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Main Concepts
Tracks
In the editor, tracks represent a single audio file, and can be positioned in 3D space to play the
audio with binaural processing. There are three types of tracks: Audio, Streaming, and
Ambisonics.
Audio Tracks
An audio track is a mono audio file imported directly into the editor. If a stereo track is imported,
only the first channel of the audio will be used. It can be repositioned, trimmed, and replayed so
a single audio file can be reused in the scene. Only .wav or .mp3 files can be imported as audio
tracks.

Streaming Tracks
A streaming track has its audio data streamed in from an external DAW such as Pro Tools. It
can also be positioned in 3D space, but any editing of the audio must be done in the DAW.

Ambisonics Tracks
An ambisonics track is a multi-channel audio file which represents a 3D sound field. Any audio
file with 4 or more channels is assumed to be an ambisonics track. Instead of being positioned
in 3D space, it can be rotated to match the orientation of the video.
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Transport
The transport uses familiar controls to control playback.

“Loop” Button: When selected, allows for looped playback
● To engage loop playback, hold down Ctrl and drag (Windows) on the timeline to select
the area you’d like to loop (Cmd drag for Mac)
“Reset Playback on Stop” Button: When selected, playback will always return back to the
position of the Blue cursor (on stop). When deselected, playback will continue from the last stop
point in the timeline.
Return to Zero button: Just to the right of the “Stop” button - brings the cursor back to zero.
Step button (frame by frame): The two buttons on the right of the image above allow for frame
by frame stepping forward or backward in time.

Keyframes
A keyframe represents a specific position and volume of a track at a specific time. They are
used to smoothly interpolate a track’s position in between keyframes. Whenever the track’s
position is adjusted in the editor, the keyframe at the selected time will be edited, or a new
keyframe will be created if there is no keyframe at that time.
Keyframes can be dragged to reposition them in time. Multiple keyframes can be dragged at
once, and by holding ctrl/command and dragging the left-most or right-most keyframe, the
keyframes can be compressed/expanded towards the other end.

Near the transport, the “Previous” and “Next” keyframe buttons allow you
to move forward or backward to the nearest keyframe (across all tracks,
not per individual track’s keyframes.)
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Ambisonics
Ambisonics approximates a 3D sound field by encoding the audio into multiple channels. The
order of the ambisonics refers to how accurate the approximation is, and the number of audio
channels is (Order + 1) ^ 2. There are multiple ways to encode the audio, in terms of channel
ordering and channel weighting. The supported channel setups in RS360 Cinema are:
Channel Order

Channel Weighting

FuMa

FuMa

ACN

SN3D

ACN

N3D

*Note: YouTube spatial audio for 360 videos require ACN/SN3D encoding

360º Video Playback
360 videos can be imported into the editor to be viewed as either monoscopic (flattened) or
equirectangular 360 video playback. To import a video, go to File>Import Video. Note: only
H.264 encoded 360 videos are supported (using the .mp4 container)

Import Audio from video
To import embedded audio from a video file, use the “Import Audio from video” command found
in “Options->Import Audio from video” menu. The audio imported will be mono (whether the
audio is either mono or stereo, it is still imported as mono); however, if the audio is quad
channels, you'll have the ability to set the ambisonic import properties.
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The Interface
The interface is broken into 3 panels: the Timeline, Scene Editor, and Video Viewer.

Scene Editor
The scene editor shows the full 3D scene of where each track is positioned. You can change
the projection mode to show the full perspective view, or only the top/side/front view.
Navigation controls in this panel include:
Middle click - pan camera
Left or right click - camera rotation
Alt click - rotate camera around center
Scroll wheel - zoom in/out
WASD - Move camera
Shift+WASD - Move camera faster
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Clicking on any tracks in the scene, and then dragging them with the transform tool will create or
modify the current keyframe underneath the playhead on the timeline.

Video Viewer
The video viewer displays the loaded video in 3 modes: Spherical, Flat, or Theater mode.
Spherical mode is used to watch 360 degree videos, and Flat mode can be used to position
sounds at exact angle offsets from the center of the video. Press ‘g’ in this mode to toggle a grid
overlay. Theater mode can be used for standard 2d videos, to position sounds as if they would
be played in a movie theater.

Video Stereoscopy
RS360 Cinema also supports 360 video with stereoscopic playback. Cameras like the
Humaneyes Vuze allow for stereo 360 video playback, which provides depth making the viewing
experience more immersive. To change the stereoscopic mode, go to the Options->Video
Stereoscopy, then choose the appropriate stereo mode. For the Vuze camera, it supports
‘top/bottom’.

HMD Support (Windows only)
RS360 Cinema supports HMD viewing with head-tracking, which allows you to monitor the video
and 3D audio live directly from RS360 Cinema. Supported HMDs include Oculus Rift (CV1),
HTC Vive, and OSVR.

Timeline
The timeline contains all of the controls for starting, stopping, and repositioning the playhead.
There are also buttons to enable/disable HMD orientation tracking, and switch the projection
mode of the video renderer. In the bottom left, there is a monitor for the final stereo output of the
program, and clicking+dragging the gain label can edit the output gain amount.
Dragging the two buttons next to the output level meter control the height of the audio tracks,
and the height of the audio waveforms.
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Playing Audio
Adding tracks
Audio tracks and Ambisonics tracks can be added by choosing File>Import Audio. Only .wav,
.mp3, or .amb files can be imported, and any file with 4 or more channels are assumed to be
ambisonics tracks.

Playback Modes
The audio playback mode can be
changed on each track individually.
The default playback mode can be
selected by choosing
Options>Default Audio Mode. The
choices are High Quality, Fast,
Ambisonics, or Passthrough mode.
High quality will play the audio with
accurate room reflections, while fast
mode will disable room reflections but processes much faster. Ambisonics mode will convert all
of the audio into ambisonics format before processing, and is similar in efficiency to fast mode.
Passthrough mode will just play the stereo or mono audio file directly.
The audio is always processed with respect to the current orientation of the video viewer. If an
HMD is attached, tracking with the HMD can be enabled or disabled with the HMD button.
NOTE: High Quality mode uses physics-based room modeling, which can be quite taxing on
less powerful machines (i.e. non-gaming desktop/laptops) If you hear artifacts (i.e. glitchy
playback), try setting the playback mode to “Fast” or Ambisonics” which removes the physical
modeling component (greatly reducing CPU usage) which should eliminate playback glitches,
pops, and clicks.
Regarding ‘Passthrough mode’, YouTube doesn’t support this feature; however, we plan on
supporting Facebook 360 video exporting with a future update which does support
“head-locked” audio playback.
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Output Level
If your output mix is too hot/low, you can increase/decrease the output level by clicking on the
bottom output meters (at the very bottom of the tracks list.)

Exporting
Exporting To Ambisonics
Ambisonics files can be exported up to
order 7, with any of the supported channel
setups.
Any pre-rendered ambisonics tracks will be
automatically converted to the specified
output setup.
If the Realtime checkbox is enabled, then
the output will be saved to a file while the
scene is also being played, so the output
can be monitored. If the audio is being
streamed from a DAW, this is the
recommended method of exporting ambisonics.
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If the Realtime checkbox is not enabled, the output will be quickly computed without playing the
sound. Note: the output file must be in the same directory as the scene file.
If the Inject into video checkbox is enabled, then the output file will be converted into a .wav file,
and the current video will be copied into a new file along with the output audio. The new file will
be named <video_name>_<output_name>.mov.
*Note: MP4 files cannot use WAV format audio, so in order to keep the .mp4 file extension, the
audio must first be converted into aac format. The audio will lose some quality in the process.

YouTube Export
With RS360 Cinema, you can conveniently export the correct ambisonic file output for YouTube.
To do so, simply go to the File-> Export -> Export Audio menu. If you have a video loaded into
the video viewer, the “Output Format” selection automatically chooses “Youtube Video”. The
“Channel Order/Weight” and the “Ambisonics Order” is automatically set to the format that
YouTube supports. Stereo mode can be selected with “none”, Top-Bottom”, and “Left-Right” as
available options. **Note: The Humaneyes Vuze camera supports stereo mode “Top-Bottom”.
Once all the desired options are set, click “Save”. An export process is executed which
automatically sets all the meta-data needed for YouTube (for both the audio and video.) Once
the process is complete, simply locate the file and upload to YouTube with no changes to the
meta-data required! **Note: YouTube uploading and processing can take several minutes to
hours; often the video is processed first then the audio (so if the ambisonic audio isn’t working
immediately, give it some time and YouTube will eventually complete the audio processing.)

Exporting Stereo Audio
The audio can also be exported with the 3d audio mixed down into a 2 channel stereo file, with
the head orientation locked looking straight ahead.

Synchronizing with a DAW
The editor can be synchronized with a DAW such as
Pro Tools through Midi Time Code (MTC). You must
have an internal virtual midi cable installed on your
computer to pass the MTC from the DAW to the editor.
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[NOTE: MIDI Machine Control is disabled for this version but will be added for an upcoming
release.]
For Mac:
All computers running OSX already have support virtual midi cables through the IAC driver.
Open the Audio MIDI Setup application, and then choose Window>Show Midi Studio. Double
click the IAC driver, and add a port to use for synchronization.
For Windows:
Multiple free virtual MIDI cable programs exist for windows platforms. One known-good solution
is the LoopBe1 driver (http://www.nerds.de/en/loopbe1.html), which is free for personal use.
Simply download and run the installer, and the option to select the LoopBe virtual midi cable will
appear as an option in the Synchronization selection window. Another solution is Loop MIDI
(http://www.tobias-erichsen.de/software/loopmidi.html) Loop MIDI is free for personal use;
however, check the license terms for commercial use.
In the editor, choose Options>Synchronize, and set the editor to slave mode, and select the
virtual midi cable from the drop down box. In the DAW, enable Midi Time Code generation
through the same virtual midi cable.
When the editor is in slave mode, all of the control buttons will be disabled, so playback can
only be started/stopped in the DAW.
In addition, it is important to know that the timeline duration defaults with the length of the
imported video. For example, if the length of the video is 2 minutes, the duration sets to 120
seconds automatically. To change the end of the timeline, the Edit->Edit Scene Parameters
window allows the user to enter a desired “Length” of the timeline.

Streaming Tracks from DAW
Streaming tracks can be added by choosing Edit>Add DAW Source. Two types of signals are
needed to drive the editor when streaming audio: Midi Time Code (MTC) and the audio. MTC
can be sent from the DAW to the editor through a virtual midi cable, and the audio can be sent
over a virtual audio cable. Enabling the MTC synchronization is explained below in the
Synchronizing with a DAW section. Setting up the virtual audio cables is done in the following
way for each operating system:
For Windows:
The Jack Audio Connection Kit can be used as a virtual audio cable to pass audio from a DAW
to the editor (http://www.jackaudio.org/). Once the jack server is setup, choose Options>Edit
Audio device in the editor, and in the Audio Device Type select ASIO, and then in the Device
select Jack Router. Enable the audio inputs, and press save. Then in the DAW, change the
playback engine to also use Jack. In the Jack Connection Kit interface, open the Connect
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window, and link any outputs from the DAW to inputs for the editor. You can save this
connection setup by opening the Patchbay and creating a new patchbay profile.
For Mac:
Audio can be passed between applications on Mac easily by using Soundflower:
https://github.com/mattingalls/Soundflower/releases/tag/2.0b2
First open the “Audio MIDI Setup”, found in the Mac’s Utilities folder, and create an aggregate
device which uses the Built-In Output and Soundflower (64ch). If you are using Pro Tools, an
aggregate device is automatically created. In the editor, choose Options>Edit Audio Device,
select the aggregate device as the output, and enable all of the inputs needed. Use the
aggregate device as the playback engine in the DAW, and any audio output to a channel in
soundflower can be used as input in the editor.
Note: Jack Audio is also available as an option for Mac (the download page is the same as
listed above in the Windows section.) The setup is a bit more complex - be sure to read the
documentation on properly setting up Jack and routing audio using Jacl Pilot.

Keyboard shortcuts
space - Play / Stop

c - toggles the center arrow which helps
point to the front/center of a 360 video

ctrl+shift+n - New Project
ctrl+e - export project to ambisonics
ctrl+s - Save Project
ctrl+z - undo
ctrl+o - Open Project
ctrl+shift+z - redo
ctrl+i - Import Audio File
delete - Delete selected keyframes
ctrl+shift+i - Add DAW source
ctrl+r - Reset scene view
ctrl+shift+v - Import Video File
ctrl+l - Reset the application layout
g - toggles the grid view when in
monoscopic mode

ctrl+c - Copy the selected keyframes
ctrl+v - Paste the copied keyframes

Notes
For a detailed walkthrough with step-by-step instructions working with RS360 Cinema, please
refer to the following guide:
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https://docs.google.com/a/visisonics.com/document/d/1CnUevWaIM9-12IkrwoRq7Q3LzmBeqqq
cu121Rs3CX0o/edit?usp=sharing
-

-

Video decoding of H.264 can be taxing on lower end systems. We highly recommend a
4th generation Intel i5 or i7 based computer (Mac or PC) to comfortably run many tracks
of audio alongside 360 video.
HMD support is a Windows only feature. This is due to the limited HMD API support for
macOS
macOS El Capitan or Yosemite recommended. (macOS Sierra not tested)

Troubleshooting:
Playback is plagued with glitches, pops and clicks
Change the playback mode to fast or ambisonics by choosing Options>Audio mode
DAW and RS360 Cinema Editor are not syncing
Make sure the following is setup properly:
1. MIDI Time Code is set up properly on your DAW.
a. Ensure the timecode frame rate are identical between RS360 Cinema and the
DAW
b. Make sure the timecode start time is the same as RS360 Cinema. For example, if
the DAW is set to a start time of 01:00:00:00, make sure RS360 Cinema is also
set to 01:00:00:00.
2. Check that the MIDI driver is set to the correct bus.
MIDI Machine Control doesn't work in RS360 Cinema
At the moment MIDI Machine Control is disabled. Will be enabled in a future update.
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