• Author
    Posts
  • #1158

    darkbeat
    Participant

    I get the following error on Windows 10:

    Failed to load ‘Assets/RealSpace3D/Plugins/x86_64/RealSpace3D_vsEngine.dll’ with error ‘The operation completed successfully.
    ‘, GetDllDirectory returned ”. If GetDllDirectory returned non empty path, check that you’re using SetDirectoryDll correctly.
    RealSpace3D.RealSpace3D_AudioListener:RunRealSpace3D_Engine()
    RealSpace3D.RealSpace3D_AudioListener:RunRealSpace3D_Engine()
    RealSpace3D.RealSpace3D_AudioListener:Awake()

  • #1160

    Rod_RealSpace3D
    Keymaster

    Hi Alex,

    You are experiencing the new Unity 5.0+ plugin selection error. Since we provide a Windows x86 and x86_64 dll you have to manually select the dll you wish to build for via the plugin inspector. If you select x86 you have to deselect the x86_64 dll in the inspector window. Unity defaults them both on so you have to select the one you wish and deselect the other.

    I believe there is an explanation detailed here on the forum how to correct and I believe it is noted in the readme file as to how to things should be set up.

    I will add a posting to the forum that shows screenshots of how the plugins should be setup for each platform. I did have a script that would adjust based on the build platform but Unity kept overwriting. I will see if that has been fixed and put our script back to automatically make the changes for the users.

    Thanks,
    Rod

  • #1162

    Rod_RealSpace3D
    Keymaster

    Here’s more info…

    http://docs.unity3d.com/Manual/PluginInspector.html

    Here’s what you have to do…

    Editor Setup for all platforms…

    * Select the in the Hierarchy window the RealSpace3D/Editor and select the realspace3deditor.dll and set to “Editor” in the Inspector window.

    Plugin Setup for Windows…

    * Select in the Hierarchy window the RealSpace3D/Plugins

    If you wish 32bit select x86/RealSpace3D_vsEngine. In the Inspector select “Any Platform” and “Standalone” and select the x86_64 RealSpace3D_vsEngine dll and unselect everything. This will stop the conflict of multiple DLLs. Note this now means you will be running the 32 bit plugin.

    If you wish 64bit then you do the reverse. Select the x86 plugin and turn off everything, and select the x86_64 and choose “Standalone” and “Any Platform”.

    Plugin for Android and other platforms just turn off the x86 and x86_64 dlls.

  • #1171

    Rod_RealSpace3D
    Keymaster

    I have researched this issue further. It appears that Unity stopped adding the Visual Studio redistributable dlls in Unity 5. If you do not already have Visual Studio running on your machine this is likely the problem. Download and install the redistributables from …

    http://www.microsoft.com/en-us/download/details.aspx?id=30679

    Please give that a try and let me know your results.

    Thanks,
    Rod

  • #1172

    Rod_RealSpace3D
    Keymaster

    It has been confirmed. The error is due to the redistributable missing. Install the Visual Studio 2012+ redists to solve the error.

  • #1173

    darkbeat
    Participant

    Thanks Rod, for continuing to look into this. Your last suggestion solved the problem – installing both the x64 and x86 versions of the 2012 C++ redistributable packages. On our Windows 10 machine, SteamVR had installed the 2005, 2010 and 2013 versions of the Visual C++ redistributables (both x64 and x86), but not 2012. I thought it must be a Windows 10 related issue, because the Unity 5 errors didn’t come up on our Windows 7 box. On Windows 7, SteamVR only installed the 2010 and 2013 redistributables, but this issue never came up. Works out of the box on my MacBook Pro as well, but I sort of expected that.

    RealSpace3D paired with the HTC Vive is awesome by the way. We’re going to be demoing at the TechCrunch Disrupt VR Pavilion in 2 weeks and our demo machine is the Windows 10 one, so this fix sort of saved the day. Thanks again. -Alex

  • #1174

    Rod_RealSpace3D
    Keymaster

    Great! Good luck at the Disrupt!

You must be logged in to reply to this topic.