• Author
    Posts
  • #817

    ianburnette
    Participant

    Anyone else gotten this error?
    DllNotFoundException: E:/Created/RealSpace3D/builds/ThePracticeRoomWin1_3_Data/Plugins/RealSpace3D_vsEngine.dll

    The game runs fine in-editor, but whenever I try a build this is the error that gets dumped into the output log. In the windows standalone, at least. I also get errors in the webplayer, but they’re not as verbose.

    I’ve made doubly sure that the dll in question definitely lives at that exact address, but nothing doing. Any ideas?

  • #818

    Rod_RealSpace3D
    Keymaster

    Set your build settings to build for 64bit. Due to a Unity error of DLLs w/ same name in x86 and x86_64 clashing we only provided the 64bit dll until the error is resolved.

  • #819

    ianburnette
    Participant

    Aha! Thanks for the quick reply. I’ll try that just as soon as I get back to my computer. While we’re on the topic, should I worry about submitting my contest entry by today at 4:00PM EST, which is (I think) the original contest deadline? The contest page now has some conflicting information (in the small print regarding submission time), and I tweeted and sent a contact email double-checking … but haven’t heard back yet and am a little worried if the deadline is this afternoon. Thanks!

    • #822

      Rod_RealSpace3D
      Keymaster

      Sorry about the confusion. I spoke w/ the guy here running the contest and he says the Unity survey has to be completed by today but the contest ends this coming Friday (June 5th).

      Good Luck! 🙂

  • #823

    ianburnette
    Participant

    Sweet! Thanks, Rod! That’ll give me a little time to polish it up (to say nothing of being able to successfully make a build!)

  • #1372

    st4rrk
    Participant

    Hi guys, I recently got the same error, so I modified the Build Settings but there is still the error, can you tell me to find what I’m doing wrong?
    ==================== ERROR ====================
    DllNotFoundException: AudioPluginRealSpace3D_vsEngine
    RealSpace3DPlatformSwitcher.RealSpace3D_PlatformSwitcher.Init3DSoundEngine (System.String sAppDataPath, Int32 kEngine, System.String sLicense, Int32 nDSPBufferSize, Int32 nSampleRate, Int32 nLoggingOn, System.String sLogFile, Double fUnitScaleFactor)
    RealSpace3D.RealSpace3D_AudioListener.RunRealSpace3D_Engine ()
    RealSpace3D.RealSpace3D_AudioListener.Awake ()
    ===============================================
    Win8_64, Unity_64
    Audio Listenner Inspector
    Audio Plugin x64
    Audio Plugin x84
    Build Settings
    Source Applause Inspector

    I hope this could help. \o/

  • #1373

    st4rrk
    Participant

    The pics was not working, here it is

    Audio Listenner Inspector : https://cdn.pbrd.co/images/1I9rQGwK.jpg
    Audio Plugin x64 : https://cdn.pbrd.co/images/1IaJgiXK.jpg
    Audio Plugin x86 : https://cdn.pbrd.co/images/1I9ABlb4.jpg
    Build Settings : https://cdn.pbrd.co/images/1I9D23V1.png
    Source Applause Inspector : https://cdn.pbrd.co/images/1I9FHa0J.jpg

  • #1374

    Rod_RealSpace3D
    Keymaster

    Hello St4rrk,

    Let’s see if we can fix your problem.

    First turn off all the options in the Plugin Inspector for the x86. If you are building for x86_64 then you need to deselect the x86. So, all the settings should be unchecked.

    If you still have the problem then grab the 2012 MSVC redistributable…http://www.microsoft.com/en-us/download/details.aspx?id=30679

    Unity starting in 5.0 did not ship this redistributable.

    Let us know if either of these solutions solved your problem.

    Thanks,
    Rod

You must be logged in to reply to this topic.